Apostila de Fórmulas de Excel

planilha.jpg

Apesar de seus recentes avanços, a função primária das planilhas ainda é fazer cálculos. A principal ferramenta para atingir esse objetivo são as fórmulas.

Para os alunos de Introdução à Informática, segue a apostila introdutória sobre fórmulas no Excel (e no Calc) que uso nas aulas práticas.

Apostila introdutória sobre fórmulas para planilhas de cálculo (170 kB).

125 comentários sobre “Apostila de Fórmulas de Excel

  1. Do muito que ja pesquisei na Internet, eu não poderia nunca deixar de parabeniza-lo pelo EXCELENTE trabalho.

    PARABENS.

  2. Boa noite pessoal, dados os elogios e a participação do pessoal aí acima resolvi perguntar. Se puderem me ajudar (pelo menos falando se é possível o que eu quero ou não) eu agradeço.

    Confesso que não pesquisei no site, mas já faz algum tempo que procuro na internet e não acho minha resposta.

    Quero saber se é possível criar uma macro que armazena um valor acumulado na própria célula onde é digitado o valor, ou seja, uma macro para quando eu digitar em A1 (3, por exemplo) e apertar enter, a célula armazena o 3, depois digito 5 e ela (A1) armazena 8, não em outra célula. Se possível, como fazer?

    Encontrei vários scripts que armazenam o acumulado mas em outra célula e até já os modifiquei, mas sem êxito exato, pois no Excel o programa retorna um erro quando direciono o código para a própria célula.

    Outra coisa, seria possível fazer esta soma acumulada somente com as fórmulas, sem recorrer ao VBA.

    Agradeço desde já.

      • Opa José Luís,

        Muito Obrigado pela dica. Estava a procurar sobre a referência circular mesmo, pois eu achava que era esse o modo de resolver meu problema, mas quando tentei o Excel retornava erro. Eu não sabia que tinha que habilitar. Muito útil mesmo, prefiro isso do que o VBA.

        Serviu sim! Muito obrigado…

        Sou muito grato mesmo, já tava tendo dor de cabeça com isso.

      • Bom dia José,

        Estou vindo incomodar novamente.
        Li o post que me indicou, fiz certo aqui, mas eis que me surgiu outro problema. Quando salvo a pasta de trabalho no Excel, ele computa novamente a célula com a soma acumulada.
        Por exemplo, fazendo B1=B1+A1 e digitando 2 em A1, B1 armazena 2, pois configurei para uma interação por vez. Daí, se A1=4, B1=6. Se eu salvo o arquivo, ele calcula novamente resultando em B1=10.

        Seria possível corrigir este problema com alguma fórmula lógica, por exemplo, a função SE(). Já pensei aqui e descobri ser um pouco complicado. Você pode me indicar alguma coisa.

        Desde já, obrigado.

  3. Olá gostaria de uma ajuda estou fazendo controle de estoque de supermercado fiz uma planilha mas gostaria de saber se tem como fazer com que quando a mercadoria estiver quase vencendo o excel me informace tipo vermelho quando javenceu verde nao vence amarelo quase vencendo tem como?

    • Lucas,

      Pelo que entendi, há uma coluna contendo a data final do prazo de validade de cada produto, correto?

      Experimente a formatação condicional (menu Formatar > Formatação condicional…), inserindo três testes comparando o valor da célula com a função HOJE(), cada um com uma cor diferente.

      Se tiver problemas, avise, ok?

  4. Alguém poder me ajudar qual a formula usar :

     A    B    C    D     E    F    G    H
    4000  0,07  2,26  13,9405%  0,16  0,02  0,18  721,02

    Tenho um problema para resolver, O valor na celular H, seria =a2*g2 = 720.

    • Émerson, certamente o valor da célula G2 é resultado de uma conta e é igual a 0,180255.

      Ele está sendo exibido como 0,18, como arredondamento, em virtude da formatação que você fez.

      Se você precisa que os resultados das células G2 e H2 sejam respectivamente 0,18 e 720, verifique novamente as fórmulas ou use a função ARRED(). Ok?

  5. Prezado Professor:
    Qual a fórmula para somar percentuais acumulados no Ecxel….???
    Exemplo: 5,42% + 7,23% + 11,45% …..= 25,99%
    Desde já, um forte abraço.

    • José Carlos, não entendi perfeitamente sua dúvida: os percentuais podem ser somados como quaisquer outros valores… No exemplo citado por você, supondo que os percentuais a serem somados estão nas células A1, A2, A3 e A4, podemos ter o somatório na célula A5 usando qualquer uma das fórmulas abaixo:

      • =A1 + A2 + A3 + A4;
      • =SOMA(A1; A2; A3; A4);
      • =SOMA(A1:A4)
      • PREZADO PROFESSOR JOSÉ LUÍS:
        Peço desculpa por não ter sido claro no meu questionamento.
        No exemplo que citei, se somarmos os três percentuais, digamos, aritmeticamente, teríamos como resultado 24,10%.
        Agora, se somarmos os percentuais acumulados, ou seja:
        100 x 5,42%= 105,42 x 7,23% = 7,62 + 105,42 = 113,04% x 11,45% = 12,94 + 113,04 = 125,99 – 100 = 25,99%.
        É para chegar a este resultado que me socorri do Senhor.
        Atenciosamente, José Carlos.

        • Agora entendi o que você deseja!

          Como você pretende acumular os percentuais aplicados (aplicando percentual sobre o anterior, mais ou menos como ocorre com os juros compostos), sugiro que considere a aplicação do percentual adicionado ao inteiro (100%). Lembre de, após o cálculo, subtrair o inteiro adicionado no processo…

          Por exemplo, considerando as células A1, A2 e A3 contém os três percentuais como propus antes, a célula A4 poderia ter a seguinte fórmula:

          =(1 + A1) * (1 + B1) * (1 + C1) - 1

          Infelizmente, não tenho feito muitos trabalhos estatísticos no Excel (nem no Calc), por isso não sei se há uma função específica para isso. Mas, para casos mais simples, creio que isso deve bastar… :wink:

Deixe um comentário: